Jump to content
Chapala.com Webboard
elpind

Getting my Roku to recognize 5ghz band

Recommended Posts

Does anybody know how to get my Roku4/Roku Premier+ to recognize my 5ghz band on my Telmex router.  I have done some searching on the web but it seems complicated to me.  I get a very strong signal on the 2.4 band but would like to use the 5ghz for less interference.  My router is next to my tv so distance is not a problem. Any help would be appreciated.

Share this post


Link to post
Share on other sites

If you have a smart TV, check and see if there is an internet input plug. My modem is also very close to the TV and I run a cable between the two. You know a cat5 or cat6 cable connection. Which is a better choice than cable

Share this post


Link to post
Share on other sites

We bought both our smart TVs before we really knew much about them.  It turns out that they are both wireless-capable and we use that feature to watch Netflix, UTube, etc.  No cables required and the modem resides in another room.

Share this post


Link to post
Share on other sites

Your Roku has an HDMI output so just buy a cheap HDMI cable and connect to one of the available ports on your TV. Then do the setup choosing wired instead of wirelessly

 

Share this post


Link to post
Share on other sites

The easiest and most complete solution, since you have the modem so close to your Roku, would be to just connect the two with an Ethernet cable.  No interference at all that way.  If you really want to use WiFi for whatever reason, it seems that the Roku4 is quite particular about what mode your modem/router is using to broadcast signals and you need to ensure that the modem/router is set to NA-mixed (or closest equivalent) before the Roku will work on 5GHz.  This is a simple settings change but I can't give exact instructions without knowing what model Telmex has given you.  Generally you want to go into the modem settings by entering its IP address (probably 192.168.1.254 or 192.168.1.1 but could be different) into a web browser on a computer connected to the same network.  You should find yourself at a login screen with the Telmex logo and a User Name/Password field.  The user name should be TELMEX in all capitals, the password should be the password printed on the modem itself.  Then find the setting for WiFi broadcast mode and change it accordingly, save and exit.  If you want exact instructions, post the model number of the Telmex mdem.

As a side note, "smart" TVs are wholly unnecessary for people using devices like Roku or KODI boxes.  The device needs the internet, your TV does not.  TV just needs an HDMI connection for picture and sound, while the "smart" stuff is handled by the device.  If you know you will be using such a device, save a bit of money and buy a non-smart (dumb?) TV.

Share this post


Link to post
Share on other sites

Thanks all for your responses.  After posting this I did a direct hookup; modem to roku to tv.  I am having good success with this but do not know if it is using the 2.4 or 5 band going to the roku.  I have looked at all categories within the settings of my roku and no mention of which band is connected directly to the roku from the router.   Previously, when I was wireless, the roku indicated I was connected to the 2.4 band.

BtD, attached is a pic of the back of my modem if you don't mind providing a bit more detail.  Previously I did access my modem, prior to your post, but could not find where to change to na or mixed from my inter net searching.  Can not agree with you more about not needing a smart tv if you have a roku, at least for my needs of IPTV, Netflix, etc.

 

IMG_1318.JPG

Share this post


Link to post
Share on other sites

Hi elpind,

Just to clear up a bit of confusion, your Roku (and any device for that matter) will use either WiFi OR the wired connection.  It is very rare indeed that a device would use both wired and wireless, and that's why now when you look at the settings page of the Roku it does not say whether it is using 2.4GHz or 5GHz: those are radio frequencies and it is using neither.  All the data that was previously being sent via radio waves is now going directly through that ethernet cable, and as soon as your Roku senses that cable connection it says to itself "perfect, to hell with the WiFi" and ceases radio communication.  A wired connection is ALWAYS better than a wireless connection, we just invented WiFi because running cables is sometimes difficult or impossible.  A wired connection is much faster, is not subject to any interference or over-the-air hacking, and leaves your WiFi free for other uses, so whenever it's convenient tech guys will use wired connections.

As for your router, the company does not seem to have a decent manual available.  Telmex has this overview which doesn't show any settings pages or procedures, but I did find a few videos on YouTube like this one.  Long story short, the settings you wanted (but don't need anymore since it's wired) are found like this:

  1. Log in to the modem (go to 192.168.1.254 in your web browser, User Name is TELMEX, Password is written on a (yellow and blue) sticker on the modem and is probably what you are using as a WiFi password (by default)
  2. On the left hand column, click "LAN Inalambrica"
  3. Again on the left column, click "5G"
  4. On the right side you now have a window full of options for the 5GHz band.  Click on the drop-down box titled "Modo Inalambrico", which is what you want to change.  It will probably be set to "802.11a----c" but you want to change that to a mixed mode.  There may be a few different mixed modes available, I can't tell from the video, but take a guess and select one that says mixed mode in the title.
  5. Click the "Guardar" button at the bottom of the page.  If you got the right mixed mode,the Roku should work wirelessly.  If not, try another mixed mode and save again until you get it right.

This is just for the future, right now you are golden with the wired connection.  Just relax and watch a movie.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...